Results 1 to 3 of 3

Thread: Problem with Electromagnets at E.O.T Cranes.

  1. #1
    Associate Engineer
    Join Date
    Sep 2011
    Posts
    1

    Problem with Electromagnets at E.O.T Cranes.

    i have checked each and everything at panel, CRD upto the Electromagnets, it is a circular magnets used for filling Transfer Car Trolley with Scrap at Steel Melt Shop, but i have noticed one thing, when i magnetize the magnet it magnetized but when i drop the magnet the DC Contactor of the magnet produces a huge flash with fire. it is also taking 120 Amp instead of 100 amp, the varister along diode also burns out while dropping the scrap means demagnetizing the electromagnet.

    which circuit i must have to check for this condition.

    and i also want to know that may i use an AC contactor instead of dc contactor, if not then y not, electromagnet works at 210 VDC.


    regards,
    Engr. Riaz

  2. #2
    I suggest a (BIG) back emf diode, provided it's installed at the DC section. During normal operation, the diode is reverse biased and does nothing. When you open the magnet, the back emf will forward bias the diode and deal with the inductive effects that I think you're experiencing.

    This will cop a bit of energy - think beer can as opposed to pencil when it comes to sizing it. And DON'T do this if you're not sure it's DC!!

  3. #3
    Associate Engineer
    Join Date
    Mar 2014
    Posts
    2
    Recheck the circuit connection as the previous poster said u can overcome the condition

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •